Troubleshooting

TinyEmpires Wiki is paid for by Ultralite Soleil, and administrated by Xugu Madison.
Jump to: navigation, search

Troubleshooting

This section will no doubt expand as new issues and solutions arise. It is by no means comprehensive. The suggestions, and that IS what they are, suggestions, made here are done with the express purpose of helping folks to help themselves when resolving little issues that may arise from time to time in standard game play. Issues due to Second Life being unstable, internet, ISP, user error or equipment failure cannot be addressed here really but hopefully one will be able to sort out what type of issue has arisen to act upon a solution. Whenever trying to diagnose a HUD issue and resolve it, finding a very low lag area that allows scripts will help a great deal, and keep from adding extra complications, a nice, empty, void sim on the mainland might be a helpful option.

Should one find that the below suggestions fail to resolve the issue, one may port back to the shop (http://slurl.com/secondlife/Kitster/149/41/53) and use the HUD replacer. Please allow the system a few moments to synchronize the old HUD's TE account with the new HUD and hand it over. Be advised, this only works for PAID for HUDs, not the demo version. All gold, land, liege information and whatnot will be present on the replacement HUD once it is worn and re-connects with the server.


* HUD Not Working

The very first thing to check is to see if one has entered an area where scripts are not allowed. At the top of the screen, to the left of where the sim name and coordinates are listed, one might notice a series of icons, if one places their mouse over the icons, one can check to be sure that none of them are the "no scripts" symbol. If that is the issue, leave the parcel/zone/sim and normal operations should resume. If that is not the case, detach and reattach the HUD and see if that gets things working again. If that fails, try moving to an area of extremely low lag, such as a mainland "void" sim, should that fail to resolve the issue, re-log and/or re-boot.

* HUD Text Overhang

The HUD text is actually displayed hovering over the "scroll" and therefore may end up extending beyond the edge of the parchment, depending upon one's screen and Second Life UI settings. The optimal setting for screen resolution is 1280 x 1024. Should a setting of 1024 x 768 or lower be in use, one can compensate for this by adjusting Second Life's UI setting in EDIT >> PREFERENCES >> GENERAL >> UI SIZE. Moving the setting to 0.750 should resolve this issue. If this is not sufficient, clicking the HUD Clock will adjust the vertical position of text just a little bit.

* HUD is Hidden

The Inventory window indicates that the HUD is indeed being worn, and yet it is not properly displayed. First, check that the HUD is indeed being "worn" on a HUD position, not as one might a piece of clothing. After confirming that the HUD is indeed attached correctly, if it is not in the "Upper Left" position (and that is available), attach the Tiny Empires HUD to the Upper Left HUD position. Use the mouse wheel to scroll down until it "zooms" into view, right click on the HUD and select EDIT. Use the arrows to slide the HUD around on screen until the desired location is found. If one detaches the HUD and "wears" it again (or double clicks it "on") the HUD will return to the last used position. If this also fails, while the TE HUD is attached, wear another HUD that attaches to a different point, then select the second (other) HUD, zoom out, no find the TE HUD, edit it and move it to the proper position. Most likely the TE HUD is rotated and only a very, very slender line on screen. Patience will pay off here. One might also select View >> Highlight Transparent to help find the HUD if it has shifted sideways somehow.

* HUD is Invisible

Reattach or re-log is usually the answer. It's an SL glitch. Sometimes going back to the trial HUD for a moment will cause the full version HUD to fix itself.

* HUD GONG Failure

If a parcel has "spatialized" sound restricted to parcel turned on, it will often not let the GONG be heard.

* Federation HUD specific issues

Ultralite is working to address these concerns specific to the new HUD, so hopefully these will all be useless in short order, however here are the issues we've noted so far.

Citizen population at zero (0) when starting up the Federation HUD - the next census in January will set the count display to rights. Please note that the Accounting tab and numbers will yet act as if there is a number displayed on the upper section.

Text only partially displaying on Federation HUD - detach and re-attach HUD. That usually fixes it right away, if not, try to find a lower lag area to do this in again (mainland void sim for example).